A5:SQL Mk-2

開発のこと、日々のこと

SQLiteのload_extensionでnot authorizedエラー

ホーム フォーラム A5:SQL Mk-2掲示板 SQLiteのload_extensionでnot authorizedエラー

このトピックには2件の返信が含まれ、2人の参加者がいます。2 週間、 2 日前 杉浦彰 さんが最後の更新を行いました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #4086 返信

    杉浦彰

    お世話になっております。杉浦と申します。

    A5:SQL Mk-2 を SQLite に接続して使わせていただいております。

    v2.12.3 では、SQLite の load_extension を SQL エディタ上で使用することができたのですが、
    v2.13.3 以降は以下のようなエラーが発生し、それができなくなっております:

    SQL : select load_extension(‘C:\Users\urasa\Downloads\extension-functions\libsqlitefunctions.dll’)
    SQL : not authorized

    可能であれば v2.12.3 と同様に load_extension を使用し続けられるとありがたいのですが、いかがでしょうか。

    〔参考情報〕
    Enable Or Disable Extension Loading
    https://www.sqlite.org/c3ref/enable_load_extension.html

    #4097 返信

    松原正和
    キーマスター

    杉浦彰さんこんにちは。
     
    SQLite の load_extension() 機能は知りませんでした。調査したところ、DB接続ライブラリのSQLite接続の機能が変更され、オプション値を設定しないと、load_extension()を実行できなくなっていたようです。

    とりあえず、今週末くらいに修正版を出します。DB接続情報に「'”load_extension()” を有効化’」のチェックを追加しますが、これはデフォルトでOFFにするかもしれないので、手動でONにしてください。

    #4101 返信

    杉浦彰

    調査ありがとうございます。デフォルト値が変わっていたのですね。
    迅速な対応感謝します。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
返信先: SQLiteのload_extensionでnot authorizedエラー
あなたの情報:




コメントは受け付けていません。