A5:SQL Mk-2

開発のこと、日々のこと

グリッドインデックスが範囲を超えています

ホーム フォーラム A5:SQL Mk-2掲示板 グリッドインデックスが範囲を超えています

  • このトピックには4件の返信、1人の参加者があり、最後にえねにより3ヶ月、 2週前に更新されました。
5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #10031 返信
    えね
    ゲスト

    PostgreSQLですが,ツリーにテーブル名を表示させた後に,裏でpsqlとかでテーブルをドロップし,A5m2で削除されたテーブルを選択すると,「グリッドインデックスが範囲を超えています」と表示され,OKを押しても,再度メッセージが表示され無限ループに陥ります。

    #10040 返信
    松原正和
    キーマスター

    えねさんこんにちは。
     
    こちらで再現しようとしたのですが、再現できませんでした。お使いのバージョンを教えていただけないでしょうか?。

    #10056 返信
    えね
    ゲスト

    最初は,version 2.17.0 beta 28前後だったと思います。
    発生したので最新に変更して,意図的に同じことをしましたが変わりませんでした。
    今は,A5m2は2.17.0.rc2(x64)です。
    Portableモードで使用していますので,設定ファイルは代々古いバージョンから引き続き使用しています。
    PostgreSQLは12.7です。

    よろしくお願いいたします。

    #10076 返信
    松原正和
    キーマスター

    えねさんこんにちは。
     
    すみません、やはり再現しませんでした。なにか、条件があるような気がするのですが、デフォルトからオプションを変更しているなどありますでしょうか?。

    #10108 返信
    えね
    ゲスト

    だいぶ古いバージョンから使い続けている(ポータブルで設定ファイルを継承し続けている)ので,よくわかりません。

    関係ありそうなところでいうと
    データベース接続は,keep alive以外チェックが入っており,
    テーブルのところは,小数点以下揃え,条件を指定して開く
    タブ,開業,コロンのところにチェックが入っています。
    PostgreSQLは,BLOBの遅延読み込みにチェックが入っています。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
返信先: グリッドインデックスが範囲を超えています
あなたの情報:




コメントは受け付けていません。