A5:SQL Mk-2

開発のこと、日々のこと

PostgreSQL scram-sha-256 の対応

ホーム フォーラム A5:SQL Mk-2掲示板 PostgreSQL scram-sha-256 の対応

  • このトピックには3件の返信、2人の参加者があり、最後に松原正和により4ヶ月前に更新されました。
4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #6098 返信
    日比宗孝
    ゲスト

    仕事、プライベートの作業で A5:SQL Mk-2 を利用させていただいております。
    使いやすく、便利なツールで普段から大変助けられており、感謝申し上げます。

    この度は、半ば要望となるのですが、確認をお願いしたいことがあり連絡差し上げました。

    PostgreSQLのバージョン10以降で、認証方式に「scram-sha-256」を利用できるようになっておりますが、A5:SQL Mk-2 の 「PostgreSQL(直接接続)」で「scram-sha-256」が設定されたデータベースサーバーへ接続しようとすると、
    「接続に失敗しました。 Unknown auth method」
    というメッセージが表示されて、接続できない状況です。

    ODBCを利用して対応していますが、ネットワーク越しの環境への接続など、ODBCを利用した対応では接続できないケースが生じており、また、やはりODBCの設定を介すのは多少なりとも手間に感じています。

    A5:SQL Mk-2 で「scram-sha-256」への対応は予定されていますでしょうか?

    既に予定がございましたら大変助かります。

    昨今のセキュリティ情勢を鑑みると PostgreSQL でも、いずれデフォルトが md5 から scram-sha-256 なりへと移行することも有り得るかと思いますので、是非、対応を検討いただきたく、お願い致します。

    #6129 返信
    松原正和
    キーマスター

    日比宗孝さんこんにちは。
     
    現在、Version 2.14系と Version 2.15系(ベータ版)は少し古いDB接続ライブラリ(UniDAC)を使用しているのですが、新しいバージョンのソースを確認したところ、scram-sha-256におそらく対応しているような感じでした。
     
    本来なら、Version 2.15系のベータ版に早めに適応したいのですが、独自パッチを適用して使用している関係上、すぐには適用できません。Version 2.15系は正式リリースまでには細心かしたいと思いますので、しばらくお待ちいただければと思います。

    #6482 返信
    日比宗孝
    ゲスト

    返信、ご案内いただき、ありがとうございます。
    また確認とお礼が遅くなり、申し訳ございません。

    2.15系で対応されるかも?ということで承知いたしました。

    #6493 返信
    松原正和
    キーマスター

    日比宗孝さんこんにちは。
     
    手元の環境で確認してみたのですが、Version 2.14系(現在の最新安定板)で既にcram-sha-256できているようでした。もしかして、Version 2.13系以前をお使いということはないでしょうか?。

4件の投稿を表示中 - 1 - 4件目 (全4件中)
返信先: PostgreSQL scram-sha-256 の対応
あなたの情報:




コメントは受け付けていません。